| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.cxf:cxf-core | ≥ 4.0.0, < 4.1.7≥ 4.2.0, < 4.2.2< 3.6.12 | 4.1.74.2.23.6.12 |
| cxf | ≥ 4.0.0, < 4.1.7≥ 4.2.0, < 4.2.2< 3.6.12 | 4.1.74.2.23.6.12 |
| build of apache camel | = 3.33.2= 4.18.1< 3.33.2< 4.18.1 | 3.33.24.18.1 |
| fuse | = 7.0.0 | |
| jboss enterprise application platform | = 7.0≥ 8.1, < 8.1.8 | 8.1.8 |
| jboss web server | = 5.0 | |
| single sign-on | = 7.0 |
Apache CXF's EndpointReferenceUtils and W3CMultiSchemaFactory classes construct a SAXParserFactory without the necessary JAXP hardening configurations, enabling out-of-band (OOB) external entity resolution. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free