In short
- CVE-2026-50157 is a MEDIUM (CVSS 6.5) vulnerability affecting auth0/symfony.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.2% of all vulnerabilities.
- Fix: update to 5.9.0 or later.
| Package | Affected versions | Patched versions |
|---|
| auth0/symfony Packagist | ≥ 5.0.0-BETA0, < 5.9.0
| 5.9.0
|
Description
Description
Applications built with the Auth0 Symphony SDK, using the Authorizer security authenticator to protect HTTP routes may accept OAuth 2.0 bearer access tokens provided through a URL query parameter, in addition to the standard Authorization header, which may increase the risk of access token exposure and replay against protected API endpoints.
Resolution
Upgrade auth0/symfony to version 5.9.0 or greater.
Acknowledgement
Okta would like to thank Alex Yeara for their discovery.
NVD description
Auth0 Symfony is a Symfony SDK for Auth0 Authentication and Management APIs. From 5.0.0-BETA0 until 5.9.0, the Authorizer::authenticate() and Authorizer::supports() paths in the Authorizer security authenticator may accept OAuth 2.0 bearer access tokens from the token URL query parameter as well as the Authorization header for protected HTTP routes. Query-string tokens can be recorded in server logs, browser history, or referrer data and then replayed against protected API endpoints. This issue is fixed in version 5.9.0.
More vulnerabilities in auth0/symfony
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free