In short
- CVE-2026-50550 is a MEDIUM (CVSS 6.3) vulnerability affecting snipe/snipe-it, snipe-it (snipeitapp).
- Chance of exploitation in the next 30 days (EPSS): 0.27%, higher than 19.2% of all vulnerabilities.
- Fix: update to 8.5.0 or later.
Description
Impact
A user who can edit other users could reset a superadmin's 2FA.
Patches
Patched in 8.5.0
NVD description
Snipe-IT is an IT asset/license management system. Prior to 8.5.0, a user who can edit other users can reset a superadmin's two-factor authentication through app/Http/Controllers/Api/UsersController.php postTwoFactorReset(). The endpoint authorizes update access but does not enforce canEditAuthFields before clearing two_factor_secret and two_factor_enrolled. This issue is fixed in version 8.5.0.
More vulnerabilities in snipe/snipe-it
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free