In short
- CVE-2026-54386 is a MEDIUM (CVSS 6.1) vulnerability affecting marimo.
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.1% of all vulnerabilities.
- Fix: update to 0.23.9 or later.
| Package | Affected versions | Patched versions |
|---|
| marimo PyPI | < 0.23.9
| 0.23.9
|
Description
marimo before 0.23.9 contains a reflected cross-site scripting vulnerability in the notebook page that allows unauthenticated attackers to inject arbitrary JavaScript by exploiting improper escaping of single quotes in the file query parameter reflected into an inline JavaScript string literal. Attackers can craft a malicious link with a payload beginning with new to bypass the 404 check and inject JavaScript into the page, which executes without Content-Security-Policy restrictions in the origin of a victim's marimo server.
NVD description
marimo before 0.23.9 contains a reflected cross-site scripting vulnerability in the notebook page that allows unauthenticated attackers to inject arbitrary JavaScript by exploiting improper escaping of single quotes in the file query parameter reflected into an inline JavaScript string literal. Attackers can craft a malicious link with a payload beginning with __new__ to bypass the 404 check and inject JavaScript into the page, which executes without Content-Security-Policy restrictions in the origin of a victim's marimo server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free