In short
- CVE-2026-54651 is a MEDIUM (CVSS 5.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.16%, higher than 5.0% of all vulnerabilities.
- Fix: update to 6.13.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.13.1
| 6.13.1
|
| pypdf | < 6.13.1
| 6.13.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires merging a file with threads/articles into a writer.
Patches
This has been fixed in pypdf==6.13.1.
Workarounds
If users cannot upgrade yet, consider applying the changes from PR #3839.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.13.1, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires merging a file with threads/articles into a writer. This vulnerability is fixed in 6.13.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free