| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/prebid/prebid-server | ≤ 0.275.0 | |
| github.com/prebid/prebid-server/v2 | ≤ 2.32.0 | |
| github.com/prebid/prebid-server/v3 | ≤ 3.30.0 | |
| github.com/prebid/prebid-server/v4 | < 4.4.0 | 4.4.0 |
| prebid server | < 4.4.0 | 4.4.0 |
Certain bidder adapters accept user-supplied parameters that are interpolated into outbound request URLs. Without proper input validation, a malicious actor could craft bid request parameters that cause the server to send HTTP requests to unintended destinations, potentially exposing internal network services or sensitive server endpoints to unauthorized access.
Patched in v4.4.0
If one is unable to update, please make sure that the affected bidder adapters are disabled.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free