In short
- CVE-2026-54908 is a MEDIUM (CVSS 6.3) vulnerability affecting github.com/pion/dtls/v3.
- Chance of exploitation in the next 30 days (EPSS): 0.54%, higher than 45.7% of all vulnerabilities.
- Fix: update to 3.1.4 or later.
Description
Impact
Remote denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message.
Patches
Upgrade to v3.1.4 or later. This version includes this patch https://github.com/pion/dtls/pull/839 which fixes the issue.
Workarounds
No work around; please upgrade to v3.1.4 or a newer version.
NVD description
Pion DTLS is a Go implementation of Datagram Transport Layer Security. Versions prior to 3.1.4 are vulnerable to Remote Denial of Service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message. This issue has been fixed in version 3.1.4.
More vulnerabilities in github.com/pion/dtls/v3
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free