In short
- CVE-2026-55478 is a MEDIUM (CVSS 5.4) vulnerability affecting snipe/snipe-it, snipe-it (snipeitapp).
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 22.1% of all vulnerabilities.
- Fix: update to 8.6.2 or later.
Description
Impact
The API endpoint for adding a license to a predefined kit (POST /api/v1/kits/{kit_id}/licenses) only checks whether the caller can edit kits, but does not perform object-level authorization on the referenced license itself. Because of this, a low-privilege user with only predefined-kit permissions can still bind a license that they should not be allowed to access or manage into a kit.
NVD description
Snipe-IT is an IT asset/license management system. Prior to 8.6.2, POST /api/v1/kits/{kit_id}/licenses checks whether the caller can edit kits but does not authorize access to the referenced license object, allowing a low-privilege user with predefined-kit permissions to bind a license they should not be able to access or manage into a kit. This issue is fixed in version 8.6.2.
More vulnerabilities in snipe/snipe-it
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free