In short
- CVE-2026-56864 is a HIGH (CVSS 7.5) vulnerability affecting golang.org/x/mod, toolchain.
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 22.5% of all vulnerabilities.
- Fix: update to 0.40.0, 1.26.6, 1.27.0-rc.3, 1.25.13 or later.
| Package | Affected versions | Patched versions |
|---|
| golang.org/x/mod Go | < 0.40.0
| 0.40.0
|
| toolchain Go | ≥ 1.26.0-0, < 1.26.6≥ 1.27.0-0, < 1.27.0-rc.3< 1.25.13
| 1.26.61.27.0-rc.31.25.13
|
Description
A malicious GOSUMDB was capable of serving arbitrary module content not contained within the transparency log.
This attack allows for a coordinating GOPROXY and GOSUMDB to serve a client malicious module content that cannot be detected by evaluating the transparency log.
In order to determine if you have been affected:
rm -r go.sum go.work.sum vendor/ && go mod tidy
NVD description
A malicious GOSUMDB was capable of serving arbitrary module content not contained within the transparency log. This attack allows for a coordinating GOPROXY and GOSUMDB to serve a client malicious module content that cannot be detected by evaluating the transparency log. In order to determine if you have been affected: rm -r go.sum go.work.sum vendor/ && go mod tidy
More vulnerabilities in golang.org/x/mod
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free