In short
- CVE-2026-58473 is a CRITICAL (CVSS 9.1) vulnerability affecting cognee.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.6% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| cognee PyPI | < 1.5.0
| 1.5.0
|
Description
Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.
NVD description
Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free