In short
- CVE-2026-59707 is a HIGH (CVSS 8.6) vulnerability affecting github.com/mudler/LocalAI.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.2% of all vulnerabilities.
- Fix: update to 1.40.1-0.20260703213242-2cbb3c96b34d or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/mudler/LocalAI Go | < 1.40.1-0.20260703213242-2cbb3c96b34d
| 1.40.1-0.20260703213242-2cbb3c96b34d
|
Description
LocalAI contains an unauthenticated server-side request forgery vulnerability in the POST /models/apply endpoint that allows attackers to fetch arbitrary internal URLs. The endpoint passes unsanitized gallery URL fields directly to gallery.GetGalleryConfigFromURLWithContext without proper validation, enabling attackers to force the server to issue HTTP GET requests to private and loopback ranges with partial response content leaked through error messages.
NVD description
LocalAI contains an unauthenticated server-side request forgery vulnerability in the POST /models/apply endpoint that allows attackers to fetch arbitrary internal URLs. The endpoint passes unsanitized gallery URL fields directly to gallery.GetGalleryConfigFromURLWithContext without proper validation, enabling attackers to force the server to issue HTTP GET requests to private and loopback ranges with partial response content leaked through error messages.
More vulnerabilities in github.com/mudler/LocalAI
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free