In short
- CVE-2026-59937 is a HIGH (CVSS 7.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.62%, higher than 49.7% of all vulnerabilities.
- Fix: update to 6.14.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.14.0
| 6.14.0
|
| pypdf | < 6.14.0
| 6.14.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with repeated malformed cross-reference streams.
Patches
This has been fixed in pypdf==6.14.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3887.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.14.0, an attacker can craft a PDF with repeated malformed cross-reference streams that cause pypdf to spend long runtimes recovering broken cross-reference table entries. This issue is fixed in version 6.14.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free