In short
- CVE-2026-59938 is a MEDIUM (CVSS 5.3) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 43.9% of all vulnerabilities.
- Fix: update to 6.14.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.14.0
| 6.14.0
|
| pypdf | < 6.14.0
| 6.14.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires loading images where the declared size values are much too large compared to the actual data.
Patches
This has been fixed in pypdf==6.14.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3888.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.14.0, an attacker can craft a PDF with declared image size values that are much too large compared to the actual data, causing large memory usage in pypdf image parsing. This issue is fixed in version 6.14.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free