In short
- CVE-2026-62240 is a HIGH (CVSS 7.4) vulnerability affecting crewai-tools, crewai (crewai).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.2% of all vulnerabilities.
- Fix: update to 1.15.1 or later.
| Package | Affected versions | Patched versions |
|---|
| crewai-tools PyPI | < 1.15.1
| 1.15.1
|
| crewai | < 1.15.1
| 1.15.1
|
Description
CrewAI before 1.15.1 contains a server-side request forgery vulnerability in the validate_url function that performs one-shot DNS resolution and blocklist checks before returning the original URL unchanged. Attackers can bypass the security filter by supplying URLs that redirect to internal addresses or use DNS rebinding techniques to access internal services and cloud metadata endpoints.
NVD description
CrewAI before 1.15.1 contains a server-side request forgery vulnerability in the validate_url function that performs one-shot DNS resolution and blocklist checks before returning the original URL unchanged. Attackers can bypass the security filter by supplying URLs that redirect to internal addresses or use DNS rebinding techniques to access internal services and cloud metadata endpoints.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free