In short
- CVE-2026-63374 is a CRITICAL (CVSS 9.3) vulnerability affecting anyio.
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 21.5% of all vulnerabilities.
- Fix: update to 4.14.2 or later.
| Package | Affected versions | Patched versions |
|---|
| anyio PyPI | < 4.14.2
| 4.14.2
|
Description
Impact
Services using internationalized (non-ASCII) domain names are potentially vulnerable to TLS connections made from AnyIO's connect_tcp() or directly via TLSStream.wrap() where the connection has (through other means) been hijacked and redirected to a malicious server. The attacker would obtain a legitimate certificate using the IDNA 2003 encoded version of the domain name and offer it to the connecting client, making the certificate validate properly on the client's end.
Patches
The vulnerability will be patched in v4.14.2.
Workarounds
Encode host names via the idna package prior to connecting.
NVD description
AnyIO is a high level asynchronous concurrency and networking framework that works on top of either Trio or asyncio. Prior to 4.14.2, connect_tcp() and TLSStream.wrap() can validate internationalized host names after the standard library converts them with IDNA 2003 instead of IDNA 2008. When a connection to a non-ASCII domain is hijacked or redirected, an attacker can obtain a legitimate certificate for the different ASCII hostname produced by IDNA 2003 and present it to the client, causing the malicious endpoint's certificate to validate. This issue is fixed in version 4.14.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free