In short
- CVE-2026-6598 is a MEDIUM (CVSS 4.3) vulnerability affecting langflow.
- Chance of exploitation in the next 30 days (EPSS): 0.15%, higher than 4.3% of all vulnerabilities.
- Fix: update to 1.9.1 or later.
| Package | Affected versions | Patched versions |
|---|
| langflow PyPI | < 1.9.1
| 1.9.1
|
Description
A security vulnerability has been detected in langflow-ai langflow up to 1.8.3. The affected element is the function create_project/encrypt_auth_settings of the file src/backend/base/Langflow/api/v1/projects.py of the component Project Creation Endpoint. Such manipulation of the argument auth_settings leads to cleartext storage in a file or on disk. The attack can be launched remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
NVD description
A security vulnerability has been detected in langflow-ai langflow up to 1.8.3. The affected element is the function create_project/encrypt_auth_settings of the file src/backend/base/Langflow/api/v1/projects.py of the component Project Creation Endpoint. Such manipulation of the argument auth_settings leads to cleartext storage in a file or on disk. The attack can be launched remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free