In short
- CVE-2026-66053 is a MEDIUM (CVSS 5.9) vulnerability affecting thrift, thrift (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 21.8% of all vulnerabilities.
- Fix: update to 0.24.0 or later.
| Package | Affected versions | Patched versions |
|---|
| thrift PyPI | < 0.24.0
| 0.24.0
|
| thrift | < 0.24.0
| 0.24.0
|
Description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings.
This issue affects Apache Thrift: before 0.24.0.
Users are recommended to upgrade to version 0.24.0, which fixes the issue.
This replaces CVE-2026-41603
NVD description
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings.
This issue affects Apache Thrift: before 0.24.0.
Users are recommended to upgrade to version 0.24.0, which fixes the issue.
This replaces CVE-2026-41603
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free