In short
- CVE-2026-71553 is a HIGH (CVSS 7.1) vulnerability affecting apostrophe.
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.2% of all vulnerabilities.
- Fix: update to 4.32.1 or later.
| Package | Affected versions | Patched versions |
|---|
| apostrophe npm | < 4.32.1
| 4.32.1
|
Description
The vulnerability is a single-request persistent DoS by submitting e.g.
"PATCH /api/v1/article/<id>" with a valid editor session and body of
{"toString.call":"x"}, overwriting the global toString function with
value x.
Fabian
NVD description
ApostropheCMS is an open-source Node.js content management system. In 4.32.0 and earlier, PATCH /api/v1/article/:id accepts the inherited path toString.call and passes it through the utility module to apos.util.set() and apos.util.get(), allowing an authenticated editor to overwrite the shared Object.prototype.toString function's call property and cause a persistent process-wide denial of service until restart.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free