In short
- CVE-2026-71870 is a LOW (CVSS 3.3) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.13%, higher than 2.2% of all vulnerabilities.
- Fix: update to 6.15.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.15.0
| 6.15.0
|
| pypdf | < 6.15.0
| 6.15.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory consumption. This requires parsing the /ToUnicode entry of a font with unusually large values, for example during text extraction.
Patches
This has been fixed in pypdf==6.15.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3944.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.15.0, a crafted PDF can cause large memory consumption when pypdf/_cmap.py function parse_bfrange parses unusually large source-code or destination-string tokens in a font /ToUnicode CMap during text extraction. This issue is fixed in 6.15.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free