In short
- CVE-2026-73415 is a HIGH (CVSS 7.5) vulnerability affecting jupyterlab.
- Chance of exploitation in the next 30 days (EPSS): 0.74%, higher than 54.5% of all vulnerabilities.
- Fix: update to 4.6.2, 4.5.10 or later.
| Package | Affected versions | Patched versions |
|---|
| jupyterlab PyPI | ≥ 4.6.0, < 4.6.2< 4.5.10
| 4.6.24.5.10
|
Description
JupyterLab's image viewer allows for cross-site scripting (XSS) when a specially-crafted image file is opened through the image viewer and then opened in a new tab. This XSS issue can be used to cause remote code execution (RCE) on the JupyterLab server.
Impact
This vulnerability allows for arbitrary code execution.
Patches
JupyterLab v4.6.2 and v4.5.10 contain the patch.
Workarounds
Disable the image viewer plugin:
jupyter labextension disable @jupyterlab/imageviewer-extension:plugin
Confirm with:
jupyter labextension list
NVD description
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. Prior to 4.5.10 and 4.6.2, in packages/imageviewer/src/widget.ts, JupyterLab's ImageViewer uses URL.createObjectURL for a specially crafted SVG image and revokes the blob URL too early, allowing the image to retain an executable same-origin context when it is opened through the image viewer and then opened in a new browser tab. The resulting cross-site scripting can be used to execute arbitrary code on the JupyterLab server. This issue is fixed in versions 4.5.10 and 4.6.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free