In short
- CVE-2026-7724 is a MEDIUM (CVSS 5.0) vulnerability affecting prefect.
- Chance of exploitation in the next 30 days (EPSS): 0.25%, higher than 16.4% of all vulnerabilities.
- Fix: update to 3.6.28.dev2 or later.
| Package | Affected versions | Patched versions |
|---|
| prefect PyPI | < 3.6.28.dev2
| 3.6.28.dev2
|
Description
A vulnerability has been found in PrefectHQ prefect up to 3.6.28.dev1. Affected by this vulnerability is the function validate_restricted_url of the component Webhook/Notification. The manipulation leads to time-of-check time-of-use. It is possible to initiate the attack remotely. The attack is considered to have high complexity. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.6.28.dev2 addresses this issue. The identifier of the patch is 7c70ac54a5e101431d83b9f2681ec88d5e0021ed. Upgrading the affected component is advised.
NVD description
A vulnerability has been found in PrefectHQ prefect up to 3.6.28.dev1. Affected by this vulnerability is the function validate_restricted_url of the component Webhook/Notification. The manipulation leads to time-of-check time-of-use. It is possible to initiate the attack remotely. The attack is considered to have high complexity. The exploitation appears to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.6.28.dev2 addresses this issue. The identifier of the patch is 7c70ac54a5e101431d83b9f2681ec88d5e0021ed. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free