In short
- CVE-2026-77567 is a HIGH (CVSS 8.1) vulnerability affecting filament/filament.
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.3% of all vulnerabilities.
- Fix: update to 4.12.0, 5.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| filament/filament Packagist | ≥ 4.0.0, < 4.12.0≥ 5.0.0, < 5.7.0
| 4.12.05.7.0
|
Description
A flaw in the challenge handling for app-based multi-factor authentication allows the second factor to be bypassed. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled.
NVD description
Filament is a collection of full-stack components for accelerated Laravel development. Prior to versions 4.12.0 and 5.7.0, incorrect challenge-form required-field handling allows app-based multi-factor authentication to be bypassed when recovery codes are enabled. Email-based multi-factor authentication is not affected. This issue is fixed in versions 4.12.0 and 5.7.0.
More vulnerabilities in filament/filament
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free