In short
- CVE-2026-78684 is a MEDIUM (CVSS 5.3) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.1% of all vulnerabilities.
- Fix: update to 0.27.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.27.0
| 0.27.0
|
| vllm | < 0.27.0
| 0.27.0
|
Description
vLLM before 0.27.0 fails to properly classify DeepStream as a GPU backend and omits pixel-limit enforcement in its decode path. Unauthenticated attackers can activate DeepStream at request time to initialize the process-wide GPU decode pool and submit video that bypasses resource controls, causing partial denial of service for concurrent requests.
NVD description
vLLM before 0.27.0 fails to properly classify DeepStream as a GPU backend and omits pixel-limit enforcement in its decode path. Unauthenticated attackers can activate DeepStream at request time to initialize the process-wide GPU decode pool and submit video that bypasses resource controls, causing partial denial of service for concurrent requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free