In short
- CVE-2026-81887 is a MEDIUM (CVSS 5.1) vulnerability affecting livewire/livewire.
- Chance of exploitation in the next 30 days (EPSS): 0.68%, higher than 52.5% of all vulnerabilities.
- Fix: update to 3.8.3, 4.3.4 or later.
| Package | Affected versions | Patched versions |
|---|
| livewire/livewire Packagist | ≥ 3.0.0-beta.1, < 3.8.3≥ 4.0.0-beta.1, < 4.3.4
| 3.8.34.3.4
|
Description
Impact
In Livewire v3 (≤ 3.8.2) and v4 (≤ 4.3.3), a vulnerability allows unauthenticated attackers to execute arbitrary JavaScript in the origin of an affected application in specific scenarios. The issue stems from how certain client-side component state is handled. This vulnerability does not affect prior major versions. Exploitation requires user interaction, but does not require authentication or prior access to the application. The issue does not bypass server-side authorisation and grants an attacker no privileges beyond those the affected user already holds.
Patches
This issue has been patched in Livewire v3.8.3 and v4.3.4. All users are strongly encouraged to upgrade to these versions or later as soon as possible.
Workarounds
There is no known workaround at this time. Users are strongly advised to upgrade to a patched version immediately.
NVD description
Livewire is a full-stack framework for Laravel. From 3.0.0-beta.1 until 3.8.3 and 4.3.4, the dot-notated query-string parser in js/plugins/history/index.js, including fromQueryString() and insertDotNotatedValueIntoData(), accepts the __proto__, constructor, and prototype path segments and creates inherited objects. Client-side state handlers then access effects.html, effects.js, effects.xjs, and effects.scripts without Object.prototype.hasOwnProperty.call(), allowing inherited attacker-controlled state to be treated as trusted effects. An unauthenticated attacker can craft a URL that, when opened by a user, executes arbitrary JavaScript in the affected application's origin. Exploitation requires user interaction and does not bypass server-side authorization or grant privileges beyond the affected user. This issue is fixed in versions 3.8.3 and 4.3.4.
More vulnerabilities in livewire/livewire
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free