In short
- CVE-2026-82258 is a MEDIUM (CVSS 4.8) vulnerability affecting sveltekit (svelte), @sveltejs/kit.
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 14.5% of all vulnerabilities.
- Fix: update to 2.60.1 or later.
| Package | Affected versions | Patched versions |
|---|
| sveltekit | ≥ 2.38.0, < 2.60.1
| 2.60.1
|
| @sveltejs/kit npm | ≥ 2.38.0, < 2.60.1
| 2.60.1
|
Description
query.batch() could, under very rare and specific timings, cause concurrent requests from different users to merge and resolve under single request context, enabling cross-user data disclosure.
NVD description
SvelteKit versions from 2.38.0 before 2.60.1 contain a race condition in query.batch that allows concurrent requests from different users to merge under a single request context. Attackers can exploit specific timing conditions to access sensitive data from other users' concurrent requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free