| Package | Affected versions | Patched versions |
|---|---|---|
| wss4j | ≥ 3.0.0, < 3.0.6≥ 4.0.0, < 4.0.2< 2.4.4 | 3.0.64.0.22.4.4 |
In the StAX streaming WS-SecurityPolicy validator, certain relative or unsupported XPath expressions can be converted into paths that never match the actual XML element path. A remote SOAP peer may therefore send a required element without the expected signature or encryption. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free