In short
- CVE-2026-90553 is a HIGH (CVSS 7.8) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 23.7% of all vulnerabilities.
- Fix: update to 0.28.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.28.0
| 0.28.0
|
| vllm | < 0.28.0
| 0.28.0
|
Description
vLLM before 0.28.0 contains a remote code execution vulnerability in the LlavaOnevision2 processor loader that ignores the trust_remote_code parameter when loading remote processor classes. Attackers can craft a malicious model with arbitrary code in processing_llava_onevision2.py that executes with vLLM process authority even when trust_remote_code is set to False.
NVD description
vLLM before 0.28.0 contains a remote code execution vulnerability in the LlavaOnevision2 processor loader that ignores the trust_remote_code parameter when loading remote processor classes. Attackers can craft a malicious model with arbitrary code in processing_llava_onevision2.py that executes with vLLM process authority even when trust_remote_code is set to False.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free