| Package | Affected versions | Patched versions |
|---|---|---|
| enterprise server | = 3.21.1≥ 3.16.0, < 3.16.19≥ 3.17.0, < 3.17.16≥ 3.18.0, < 3.18.10≥ 3.19.0, < 3.19.7≥ 3.20.0, < 3.20.3 | 3.16.193.17.163.18.103.19.73.20.3 |
A server-side request forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to send crafted requests to internal services by exploiting insufficient input validation in an upload endpoint. By injecting path traversal content into request parameters, an attacker could bypass the intended request flow and redirect internal API calls, potentially accessing internal services and exposing sensitive credentials. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.17, 3.18.11, 3.19.8, 3.20.4, and 3.21.2. This vulnerability was reported via the GitHub Bug Bounty program.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free