In short
- CVE-2026-93436 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.76%, higher than 55.1% of all vulnerabilities.
- Fix: update to 0.30.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.30.0
| 0.30.0
|
| vllm | ≤ 0.29.0
| No fix yet |
Description
vLLM through 0.29.0 fails to properly clean up decode-side metadata for rejected inference requests in prefill/decode disaggregated deployments. Remote attackers can submit requests with max_tokens=0 to exhaust decode-worker memory without bound until the worker restarts.
NVD description
vLLM through 0.29.0 fails to properly clean up decode-side metadata for rejected inference requests in prefill/decode disaggregated deployments. Remote attackers can submit requests with max_tokens=0 to exhaust decode-worker memory without bound until the worker restarts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free