| Package | Affected versions | Patched versions |
|---|---|---|
| imagemagick | ≥ 7.0.0-0, < 7.1.2-31< 6.9.13-56 | 7.1.2-316.9.13-56 |
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free