In short
- CVE-2026-93592 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.54%, higher than 45.7% of all vulnerabilities.
- Fix: update to 0.28.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.28.0
| 0.28.0
|
| vllm | < 0.28.0
| 0.28.0
|
Description
vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.
NVD description
vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free