In short
- CVE-2026-94622 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.1% of all vulnerabilities.
- Fix: update to 0.30.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.30.0
| 0.30.0
|
| vllm | ≤ 0.29.0
| No fix yet |
Description
vLLM versions through 0.29.0 contain a denial of service vulnerability in the NIXL connector's metadata handling for prefill/decode disaggregated deployments. Attackers can send requests with incomplete kv_transfer_params dictionary entries to trigger an uncaught KeyError in EngineCore scheduling, causing the decode engine to terminate and making all routed requests fail until manual restart.
NVD description
vLLM versions through 0.29.0 contain a denial of service vulnerability in the NIXL connector's metadata handling for prefill/decode disaggregated deployments. Attackers can send requests with incomplete kv_transfer_params dictionary entries to trigger an uncaught KeyError in EngineCore scheduling, causing the decode engine to terminate and making all routed requests fail until manual restart.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free