In short
- CVE-2026-94623 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.1% of all vulnerabilities.
- Fix: update to 0.30.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.30.0
| 0.30.0
|
| vllm | ≤ 0.29.0
| No fix yet |
Description
vLLM through 0.29.0 contains a denial of service vulnerability in the NIXL connector's prefix caching implementation that fails to properly validate block counts across multi-prompt completion requests in prefill/decode disaggregated deployments. Attackers can trigger an assertion failure in NixlBaseConnectorWorker._apply_prefix_caching by submitting completion requests with multiple prompts of varying lengths, causing the decode worker to terminate and become unavailable until restarted.
NVD description
vLLM through 0.29.0 contains a denial of service vulnerability in the NIXL connector's prefix caching implementation that fails to properly validate block counts across multi-prompt completion requests in prefill/decode disaggregated deployments. Attackers can trigger an assertion failure in NixlBaseConnectorWorker._apply_prefix_caching by submitting completion requests with multiple prompts of varying lengths, causing the decode worker to terminate and become unavailable until restarted.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free