In short
- CVE-2026-94625 is a MEDIUM (CVSS 5.3) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 44.3% of all vulnerabilities.
- Fix: update to 0.30.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.30.0
| 0.30.0
|
| vllm | ≤ 0.29.0
| No fix yet |
Description
vLLM through 0.29.0 contains a resource exhaustion vulnerability in MooncakeConnector where rejected prefill requests create ownerless transfer placeholders that are never reclaimed. Attackers can send rejected requests to exhaust sender task pools, causing valid requests to be delayed by up to 480 seconds while health checks continue returning success.
NVD description
vLLM through 0.29.0 contains a resource exhaustion vulnerability in MooncakeConnector where rejected prefill requests create ownerless transfer placeholders that are never reclaimed. Attackers can send rejected requests to exhaust sender task pools, causing valid requests to be delayed by up to 480 seconds while health checks continue returning success.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free