In short
- CVE-2026-94626 is a HIGH (CVSS 7.5) vulnerability affecting vllm, vllm (vllm).
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.1% of all vulnerabilities.
- Fix: update to 0.30.0 or later.
| Package | Affected versions | Patched versions |
|---|
| vllm PyPI | < 0.30.0
| 0.30.0
|
| vllm | ≤ 0.29.0
| No fix yet |
Description
vLLM through 0.29.0 fails to validate the tp_size parameter in kv_transfer_params on OpenAI-compatible completion endpoints, allowing attackers to allocate unbounded memory. Attackers can supply arbitrary tp_size values in prefill/decode disaggregated deployments to exhaust memory and trigger kernel OOM-kill of the decode worker process.
NVD description
vLLM through 0.29.0 fails to validate the tp_size parameter in kv_transfer_params on OpenAI-compatible completion endpoints, allowing attackers to allocate unbounded memory. Attackers can supply arbitrary tp_size values in prefill/decode disaggregated deployments to exhaust memory and trigger kernel OOM-kill of the decode worker process.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free