In short
- CVE-2026-9795 is a HIGH (CVSS 7.3) vulnerability affecting org.keycloak:keycloak-services.
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 29.1% of all vulnerabilities.
- Fix: update to 26.6.4 or later.
Description
Description
A flaw was found in Keycloak's Fine-Grained Admin Permissions (FGAPv2) feature. An administrator with limited client management permissions can exploit this vulnerability to assign any realm role, including highly privileged roles, to a client's scope mapping. This bypasses intended security controls, allowing the injected role to be projected into a user's authentication token when they access the modified client. This could lead to unauthorized privilege escalation within the Keycloak realm.
NVD description
A flaw was found in Keycloak's Fine-Grained Admin Permissions (FGAPv2) feature. An administrator with limited client management permissions can exploit this vulnerability to assign any realm role, including highly privileged roles, to a client's scope mapping. This bypasses intended security controls, allowing the injected role to be projected into a user's authentication token when they access the modified client. This could lead to unauthorized privilege escalation within the Keycloak realm.
More vulnerabilities in org.keycloak:keycloak-services
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free