| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/cosmos/evm | ≥ 0.3.0, < 0.3.2≥ 0.4.0, < 0.4.2 | 0.3.20.4.2 |
Patched in versions v0.3.1, v0.4.2, and in the v0.5.0 release. More information will be disclosed at a later point to ensure chains have time to safely upgrade.
No workarounds for chains that make use of static or dynamic precompiles. Upgrading is strongly recommended.
Tests are introduced in every affected version.
Special thanks to @yihuang for the help on this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free