| Package | Affected versions | Patched versions |
|---|---|---|
| handlebars | ≥ 4.0.0, < 4.5.3< 3.0.8 | 4.5.33.0.8 |
Versions of handlebars prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a previous issue. This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting).
Upgrade to version 3.0.8, 4.5.3 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free