In short
- GHSA-qc7w-4567-84wv is a CRITICAL (CVSS 9.8) vulnerability affecting zendframework/zendframework.
- Fix: update to 2.1.6, 2.2.6 or later.
Description
Numerous components utilizing PHP's DOMDocument, SimpleXML, and xml_parse functionality are vulnerable to two types of attacks:
- XML eXternal Entity (XXE) Injection attacks. The above mentioned extensions are insecure by default, allowing external entities to be specified by adding a specific DOCTYPE element to XML documents and strings. By exploiting this vulnerability an application may be coerced to open arbitrary files and/or TCP connections.
- XML Entity Expansion (XEE) vectors, leading to Denial of Service vectors. XEE attacks occur when the XML DOCTYPE declaration includes XML entity definitions that contain either recursive or circular references; this leads to CPU and memory consumption, making Denial of Service exploits trivial to implement.
More vulnerabilities in zendframework/zendframework
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free