Kurz gesagt
- CVE-2014-3743 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in marked (marked project), marked.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 77.4% aller Schwachstellen.
- Abhilfe: auf 0.3.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.1
| 0.3.1
|
| marked npm | < 0.3.1
| 0.3.1
|
Description
Versions 0.3.0 and earlier of marked are affected by two cross-site scripting vulnerabilities, even when sanitize: true is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
NVD description
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free