| Package | Affected versions | Patched versions |
|---|---|---|
| symfony/http-kernel | ≥ 2.3.19, < 2.3.29≥ 2.4.9, ≤ 2.4.10≥ 2.5.4, < 2.5.12≥ 2.6.0, < 2.6.8 | 2.3.292.5.122.6.8 |
| symfony/symfony | ≥ 2.3.19, < 2.3.29≥ 2.4.9, ≤ 2.4.10≥ 2.5.4, < 2.5.12≥ 2.6.0, < 2.6.8 | 2.3.292.5.122.6.8 |
| symfony | = 2.3.19= 2.3.20= 2.3.21= 2.3.22= 2.3.23= 2.3.24= 2.3.25= 2.3.26= 2.3.27= 2.3.28= 2.4.10= 2.4.9= 2.5.10= 2.5.11= 2.5.4= 2.5.5= 2.5.6= 2.5.7= 2.5.8= 2.5.9= 2.6.0= 2.6.1= 2.6.3= 2.6.4= 2.6.5= 2.6.6= 2.6.7 |
FragmentListener in the HttpKernel component in Symfony 2.3.19 through 2.3.28, 2.4.9 through 2.4.10, 2.5.4 through 2.5.11, and 2.6.0 through 2.6.7, when ESI or SSI support enabled, does not check if the _controller attribute is set, which allows remote attackers to bypass URL signing and security rules by including (1) no hash or (2) an invalid hash in a request to /_fragment.
This issue has been fixed in Symfony 2.3.29, 2.5.12, and 2.6.8. Note that no fixes are provided for Symfony 2.4 as it's not maintained anymore.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free