Kurz gesagt
- CVE-2015-5654 ist eine Schwachstelle (MITTEL (CVSS 4.3)) in dojo (dojotoolkit), dojo.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.2%, höher als bei 82.7% aller Schwachstellen.
- Abhilfe: auf 1.9.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| dojo | ≤ 1.1.1
| No fix yet |
| dojo npm | < 1.9.1
| 1.9.1
|
Description
Versions of dojo prior to 1.2.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize HTML code in user-controlled input, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 1.2.0 or later.
NVD description
Cross-site scripting (XSS) vulnerability in Dojo Toolkit before 1.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free