Kurz gesagt
- CVE-2016-10539 ist eine Schwachstelle (HOCH (CVSS 7.5)) in negotiator (negotiator project), negotiator.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.4%, höher als bei 72.5% aller Schwachstellen.
- Abhilfe: auf 0.6.1 oder neuer aktualisieren.
Description
Affected versions of negotiator are vulnerable to regular expression denial of service attacks, which trigger upon parsing a specially crafted Accept-Language header value.
Recommendation
Update to version 0.6.1 or later.
NVD description
negotiator is an HTTP content negotiator for Node.js and is used by many modules and frameworks including Express and Koa. The header for "Accept-Language", when parsed by negotiator 0.6.0 and earlier is vulnerable to Regular Expression Denial of Service via a specially crafted string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free