Kurz gesagt
- CVE-2016-10551 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in waterline-sequel (balderdash), waterline-sequel.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.8%, höher als bei 78.2% aller Schwachstellen.
- Abhilfe: auf 0.5.1 oder neuer aktualisieren.
Description
Affected versions of waterline-sequel are vulnerable to SQL injection in cases where user input is passed into the like, contains, startsWith, or endsWith methods.
Recommendation
Upgrade to at least version 0.5.1
NVD description
waterline-sequel is a module that helps generate SQL statements for Waterline apps Any user input that goes into Waterline's `like`, `contains`, `startsWith`, or `endsWith` will end up in waterline-sequel with the potential for malicious code. A malicious user can input their own SQL statements in waterline-sequel 0.50 that will get executed and have full access to the database.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free