Kurz gesagt
- CVE-2016-10557 ist eine Schwachstelle (HOCH (CVSS 8.1)) in appium-chromedriver (appium), appium-chromedriver.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.1%, höher als bei 65.6% aller Schwachstellen.
- Abhilfe: auf 2.9.4 oder neuer aktualisieren.
Description
Affected versions of appium-chromedriver insecurely download resources over HTTP.
In scenarios where an attacker has a privileged network position, they can modify or read items send over HTTP at will. In this case, that includes the chromedriver binary, which may result in remote code execution if overwritten with a malicious binary.
Recommendation
Update to version 2.9.4 or later.
NVD description
appium-chromedriver is a Node.js wrapper around Chromedriver. Versions below 2.9.4 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free