Kurz gesagt
- CVE-2016-10562 ist eine Schwachstelle (HOCH (CVSS 8.1)) in iedriver (iedriver project), iedriver.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 76.7% aller Schwachstellen.
- Abhilfe: auf 3.0.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| iedriver | < 3.0.0
| 3.0.0
|
| iedriver npm | < 3.0.0
| 3.0.0
|
Description
Affected versions of iedriver insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running iedriver.
Recommendation
Update to iedriver version 3.0.0 or greater.
NVD description
iedriver is an NPM wrapper for Selenium IEDriver. iedriver versions below 3.0.0 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free