Kurz gesagt
- CVE-2016-10571 ist eine Schwachstelle (HOCH (CVSS 8.1)) in bkjs-wand (bkjs-wand project), bkjs-wand.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 76.7% aller Schwachstellen.
- Abhilfe: auf 0.3.2 oder neuer aktualisieren.
Description
Affected versions of bkjs-wand insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running bkjs-wand.
Recommendation
Update to version 0.3.2 or later.
NVD description
bkjs-wand is imagemagick wand support for node.js and backendjs bkjs-wand versions lower than 0.3.2 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free