Kurz gesagt
- CVE-2016-20018 ist eine Schwachstelle (HOCH (CVSS 7.5)) in knex (knexjs), knex.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.1%, höher als bei 66.2% aller Schwachstellen.
- Abhilfe: auf 2.4.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| knex | ≤ 2.3.0
| No fix yet |
| knex npm | < 2.4.0
| 2.4.0
|
Description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
NVD description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free