Kurz gesagt
- CVE-2016-2537 ist eine Schwachstelle (HOCH (CVSS 7.5)) in is my json valid (is my json valid project), is-my-json-valid.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.8%, höher als bei 79.2% aller Schwachstellen.
- Abhilfe: auf 2.12.4 oder neuer aktualisieren.
Description
Version of is-my-json-valid before 2.12.4 are vulnerable to regular expression denial of service (ReDoS) via the email validation function.
Recommendation
Update to version 2.12.4 or later.
NVD description
The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free