Kurz gesagt
- CVE-2017-1001002 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in math.js (mathjs), mathjs.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.4%, höher als bei 83.8% aller Schwachstellen.
- Abhilfe: auf 3.17.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| math.js | ≤ 3.17.0
| No fix yet |
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Recommendation
Update to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free